Luscii - Priority 3: PPG report occasionally not visible for Happitech measurement – Incident details

Customer portal experiencing major outage

Priority 3: PPG report occasionally not visible for Happitech measurement

Identified
Degraded performance
Started 6 days ago

Affected

Luscii Web App

Degraded performance from 11:02 AM to 12:00 AM

Updates
  • Identified
    UTC
    Identified

    We have identified the cause. The report is delivered by our measurement partner Happitech and in incidental cases it is not included. This affects a very small share of all Happitech measurements.

    On iPhones this is already handled well: if the report is not delivered, the measurement is not saved and the patient can simply take a new measurement straight away. So a measurement without its report never ends up in the patient record. On Android devices, in those incidental cases, the measurement is correctly saved but without the report, which is exactly what we have seen.

    We are therefore aligning Android with iOS: if the report is missing, the measurement is not saved and the patient simply takes a new measurement. That way, a saved measurement is always complete. We will let you know once that change has been rolled out.

    In addition, the structural fix sits with Happitech: they need to resolve this in their own software. We have raised this with them as urgent and are actively following up.

  • Investigating
    UTC
    Investigating

    Complication:
    In rare cases, the report accompanying a Happitech measurement is not shown. This affects a small number of measurements: the measurement itself is received correctly and alerts continue to work as normal. For organisations that (partly) base care on the report, this means they cannot fully assess what happened during the measurement in those isolated cases.

    Next steps:
    Because the report is important to some organisations in their care delivery, we have raised the priority. We are investigating (with Happitech) in which situations the report is missing. We will keep you posted as soon as we know more.