Luscii - Priority 2: Recording of measurements for patients enrolled in multiple programmes – Incident details

Customer portal experiencing major outage

Priority 2: Recording of measurements for patients enrolled in multiple programmes

Monitoring
Degraded performance
Started 2 days ago

Affected

Luscii Android App

Degraded performance from 1:07 PM to 1:38 PM, Operational from 1:38 PM to 12:00 AM

Updates
  • Monitoring
    UTC
    Monitoring

    Update:

    Our investigation has shown that what initially appeared to be a single problem in fact had two separate causes. Both occur only in the Android app and only for patients enrolled in more than one programme at the same time; neither occurs on iPhone.

    Importantly, no data has been lost. Every measurement was recorded - in a small number of cases it was simply filed under the wrong programme belonging to the same patient.

    The first pattern involves scheduled measurements and is very rare, affecting a small number of patients. The second pattern involves separate, self-added measurements and affects a somewhat larger but still limited group of patients.

    We have implemented a fix so the issue can no longer occur, and we are making additional improvements in the next app release. If this issue has occurred within your organisation, Luscii will contact you about it.

  • Update
    UTC
    Update

    We are currently mapping the definitive scope. So far this still appears to concern a small number of isolated cases, affecting very few patients. In addition, we have identified a possible scenario that may explain the issue. As soon as we know more, we will post an update.

  • Investigating
    UTC
    Investigating

    Complication:

    For patients enrolled in more than one programme at the same time, a single measurement may in some cases be recorded under the wrong programme and, where applicable, the associated alert. As far as currently known, this concerns only a very small amount of patients. The measurement is not lost, but it may not appear in the programme where it belongs.

    Next steps:

    We are investigating the cause as a priority. We expect to provide an update later today, and will report back sooner as soon as we know more.