Luscii - Priority 2 issue: App fails to start on iOS 17 – specific cases (v2.93.0) – Incident details

Luscii Web App experiencing degraded performance

Priority 2 issue: App fails to start on iOS 17 – specific cases (v2.93.0)

Resolved
Degraded performance
Started 2 months agoLasted 2 days

Affected

Luscii iOS App

Degraded performance from 1:12 PM to 7:53 AM, Operational from 7:53 AM to 7:53 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Update

    • New app version 2.93.1 is available in the App Store.

    • iOS 17 users can launch the Luscii app again.

    • Please update; previous work-arounds are no longer required.

  • Investigating
    Investigating

    Situation

    • App version 2.93.0 opens briefly and then immediately closes on some devices running iOS 17 (Apple).

    • The issue does not occur on iOS 18 or iOS 26.

    • Versions earlier than iOS 17 are not supported.

    Complication

    • A subset of iOS 17 patients cannot use the app.

    • The exact conditions under which the issue occurs have not yet been fully determined.

    Next steps

    • Temporary workaround

      • Update the device to iOS 18 if possible.

      • Or sign in on another device that is not on iOS 17, e.g., a family member’s tablet or phone.

    • Luscii is working with high urgency to:

      1. Determine the full extent of the issue.

      2. Develop and roll out a permanent solution.

    Updates will follow as soon as they are available.